import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*Out:)(0x[0-9a-f]{1,8}) In:0x[0-9a-f]{1,8}\\.([0-9a-f]{1,8}).";
final String string = "2020-11:11:17.401 KEYWORD: Out:0xaaaf0000 In:0x80000000.1110ffff.\n";
final String subst = "\\2:\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}