import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(\\s*[+-\\/*]\\s*\\d+)+$";
final String string = "7 ++++ 5 --- 6 + 5\n"
+ "7 + 3 + + 5\n"
+ "7 + 3 + 5\n"
+ "7+4\n"
+ "3+4+6\n"
+ "3 ++ + 5\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}