import re
regex = re.compile(r"^\d+(\s*[+-\/*]\s*\d+)+$", flags=re.MULTILINE)
test_str = ("7 ++++ 5 --- 6 + 5\n"
"7 + 3 + + 5\n"
"7 + 3 + 5\n"
"7+4\n"
"3+4+6\n"
"3 ++ + 5\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)