const regex = /^\d+(\s*[+-\/*]\s*\d+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(\\s*[+-\\\/*]\\s*\\d+)+$', 'gm')
const str = `7 ++++ 5 --- 6 + 5
7 + 3 + + 5
7 + 3 + 5
7+4
3+4+6
3 ++ + 5
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);