$re = '/^\d+(\s*[+-\/*]\s*\d+)+$/m';
$str = '7 ++++ 5 --- 6 + 5
7 + 3 + + 5
7 + 3 + 5
7+4
3+4+6
3 ++ + 5
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;