re = /^\d+(\s*[+-\/*]\s*\d+)+$/m
str = '7 ++++ 5 --- 6 + 5
7 + 3 + + 5
7 + 3 + 5
7+4
3+4+6
3 ++ + 5
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result