using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^https?\:\/\/|(\/|\?).*$)";
string input = @"http://example.org
http://www.example.org
https://example.org
https://example.org/some-stuff/or-other
example.org?some-stuff=foo&other=bar
example.org/?some-stuff=foo&other=bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}