package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^https?\:\/\/|(\/|\?).*$)`)
var str = `http://example.org
http://www.example.org
https://example.org
https://example.org/some-stuff/or-other
example.org?some-stuff=foo&other=bar
example.org/?some-stuff=foo&other=bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}