re = /(^https?\:\/\/|(\/|\?).*$)/m
str = 'http://example.org
http://www.example.org
https://example.org
https://example.org/some-stuff/or-other
example.org?some-stuff=foo&other=bar
example.org/?some-stuff=foo&other=bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end