import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^https?\\:\\/\\/|(\\/|\\?).*$)";
final String string = "http://example.org\n"
+ "http://www.example.org\n"
+ "https://example.org\n"
+ "https://example.org/some-stuff/or-other\n"
+ "example.org?some-stuff=foo&other=bar\n"
+ "example.org/?some-stuff=foo&other=bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}