$re = '/(^https?\:\/\/|(\/|\?).*$)/m';
$str = 'http://example.org
http://www.example.org
https://example.org
https://example.org/some-stuff/or-other
example.org?some-stuff=foo&other=bar
example.org/?some-stuff=foo&other=bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);