#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w{8}-\w{4}-\w{4}-\w{4}-\w{12}"
Local $sString = "data/vms/uuid=1a874c81-9e38-4c4f-bcfa-1b52094f2c8b/flavor/ram_mib"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")