re = /\w{8}-\w{4}-\w{4}-\w{4}-\w{12}/
str = 'data/vms/uuid=1a874c81-9e38-4c4f-bcfa-1b52094f2c8b/flavor/ram_mib'
# Print the match result
str.match(re) do |match|
puts match.to_s
end