use strict;
my $str = 'data/vms/uuid=1a874c81-9e38-4c4f-bcfa-1b52094f2c8b/flavor/ram_mib';
my $regex = qr/\w{8}-\w{4}-\w{4}-\w{4}-\w{12}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}