const regex = /\w{8}-\w{4}-\w{4}-\w{4}-\w{12}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w{8}-\\w{4}-\\w{4}-\\w{4}-\\w{12}', '')
const str = `data/vms/uuid=1a874c81-9e38-4c4f-bcfa-1b52094f2c8b/flavor/ram_mib`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}