#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\[(?!.+?:)([^\]\[]+)\|([^\]\[]+)\]\]"
Local $sString = "Don't match [[Category:test]]" & @CRLF & _
"Don't match [[Category:test|blabla]]" & @CRLF & _
"Don't match [[Problem]] non link text [[Another link|problemAgain]]" & @CRLF & _
"Match [[test|Test]]" & @CRLF & _
"Match [[again|yep]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")