using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(?!.+?:)([^\]\[]+)\|([^\]\[]+)\]\]";
string input = @"Don't match [[Category:test]]
Don't match [[Category:test|blabla]]
Don't match [[Problem]] non link text [[Another link|problemAgain]]
Match [[test|Test]]
Match [[again|yep]]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}