re = /\[\[(?!.+?:)([^\]\[]+)\|([^\]\[]+)\]\]/
str = 'Don\'t match [[Category:test]]
Don\'t match [[Category:test|blabla]]
Don\'t match [[Problem]] non link text [[Another link|problemAgain]]
Match [[test|Test]]
Match [[again|yep]]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end