$re = '/\[\[(?!.+?:)([^\]\[]+)\|([^\]\[]+)\]\]/';
$str = 'Don\'t match [[Category:test]]
Don\'t match [[Category:test|blabla]]
Don\'t match [[Problem]] non link text [[Another link|problemAgain]]
Match [[test|Test]]
Match [[again|yep]]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);