import Foundation
let pattern = #"\[\[(?!.+?:)([^\]\[]+)\|([^\]\[]+)\]\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Don't match [[Category:test]]
Don't match [[Category:test|blabla]]
Don't match [[Problem]] non link text [[Another link|problemAgain]]
Match [[test|Test]]
Match [[again|yep]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}