package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?\bWASHER\s+FLAT\s+10MM\s+SS\b.*`)
var str = `4078. F00010 WASHER FLAT 20MM GALV
4078. F00010 WASHER FLAT 10MM SS
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}