import re
regex = re.compile(r".*?\bWASHER\s+FLAT\s+10MM\s+SS\b.*", flags=re.MULTILINE)
test_str = ("4078. F00010 WASHER FLAT 20MM GALV\n"
"4078. F00010 WASHER FLAT 10MM SS\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")