re = /.*?\bWASHER\s+FLAT\s+10MM\s+SS\b.*/m
str = '4078. F00010 WASHER FLAT 20MM GALV
4078. F00010 WASHER FLAT 10MM SS
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end