// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?\bWASHER\s+FLAT\s+10MM\s+SS\b.*").unwrap();
let string = "4078. F00010 WASHER FLAT 20MM GALV
4078. F00010 WASHER FLAT 10MM SS
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}