import Foundation
let pattern = #"[^a-z\d]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a{b}c'=%""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)