using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{3}\.\d{3}\.\d{3}\-\d{2})$";
string substitution = @"CNPJ";
string input = @"190.521.157-89";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}