// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d{3}\.\d{3}\.\d{3}\-\d{2})$").unwrap();
let string = "190.521.157-89";
let substitution = "CNPJ";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}