import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?=.{1,10}$)\\d{1,3}(?:,\\d{3})+|(?=.{1,8}$)\\d+)$";
final String string = "20\n"
+ "3000\n"
+ "4,000\n"
+ "600000\n"
+ "7,000,000\n"
+ "8000000\n"
+ "7,00\n"
+ "9,99\n"
+ "9,999\n"
+ "6,000,000\n"
+ "987654\n"
+ "2000,000\n"
+ "99999999\n"
+ "999999999\n"
+ "99,999,999\n"
+ "999,999,999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}