const regex = /^(?:(?=.{1,10}$)\d{1,3}(?:,\d{3})+|(?=.{1,8}$)\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?=.{1,10}$)\\d{1,3}(?:,\\d{3})+|(?=.{1,8}$)\\d+)$', 'gm')
const str = `20
3000
4,000
600000
7,000,000
8000000
7,00
9,99
9,999
6,000,000
987654
2000,000
99999999
999999999
99,999,999
999,999,999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}