$re = '/^(?:(?=.{1,10}$)\d{1,3}(?:,\d{3})+|(?=.{1,8}$)\d+)$/m';
$str = '20
3000
4,000
600000
7,000,000
8000000
7,00
9,99
9,999
6,000,000
987654
2000,000
99999999
999999999
99,999,999
999,999,999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);