import Foundation
let pattern = #"^(?:(?=.{1,10}$)\d{1,3}(?:,\d{3})+|(?=.{1,8}$)\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
20
3000
4,000
600000
7,000,000
8000000
7,00
9,99
9,999
6,000,000
987654
2000,000
99999999
999999999
99,999,999
999,999,999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)