package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0*(?:10{3,})*1?0*$`)
var str = `000100010000001000100000010000000001
100010100
0100000000000100
10010000001
1000100000100010000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}