// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0*(?:10{3,})*1?0*$").unwrap();
let string = "000100010000001000100000010000000001
100010100
0100000000000100
10010000001
1000100000100010000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}