$re = '/^0*(?:10{3,})*1?0*$/m';
$str = '000100010000001000100000010000000001
100010100
0100000000000100
10010000001
1000100000100010000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);