import re
regex = re.compile(r"^0*(?:10{3,})*1?0*$", flags=re.MULTILINE)
test_str = ("000100010000001000100000010000000001\n"
"100010100\n"
"0100000000000100\n"
"10010000001\n"
"1000100000100010000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")