re = /^0*(?:10{3,})*1?0*$/m
str = '000100010000001000100000010000000001
100010100
0100000000000100
10010000001
1000100000100010000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end