#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^,]*[,][^,]*[,][1][,]"
Local $sString = "402121,,0,23/10/2015 10:57,9/11/2015 19:00,46789,Cheese and Ham Pasta,,0,,,,,1,,1" & @CRLF & _
"407057,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Deep Fried Soft-Shell Crab and Oyster,,,,,,,1,,1" & @CRLF & _
"407062,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1" & @CRLF & _
"407062,a,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1" & @CRLF & _
"407062,aa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1" & @CRLF & _
"407062,aaaa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")