import Foundation
let pattern = #"[^,]*[,][^,]*[,][1][,]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
402121,,0,23/10/2015 10:57,9/11/2015 19:00,46789,Cheese and Ham Pasta,,0,,,,,1,,1
407057,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Deep Fried Soft-Shell Crab and Oyster,,,,,,,1,,1
407062,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,a,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aaaa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)