package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,]*[,][^,]*[,][1][,]`)
var str = `402121,,0,23/10/2015 10:57,9/11/2015 19:00,46789,Cheese and Ham Pasta,,0,,,,,1,,1
407057,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Deep Fried Soft-Shell Crab and Oyster,,,,,,,1,,1
407062,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,a,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aaaa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}