// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^,]*[,][^,]*[,][1][,]").unwrap();
let string = "402121,,0,23/10/2015 10:57,9/11/2015 19:00,46789,Cheese and Ham Pasta,,0,,,,,1,,1
407057,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Deep Fried Soft-Shell Crab and Oyster,,,,,,,1,,1
407062,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,a,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aaaa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}