use strict;
my $str = '402121,,0,23/10/2015 10:57,9/11/2015 19:00,46789,Cheese and Ham Pasta,,0,,,,,1,,1
407057,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Deep Fried Soft-Shell Crab and Oyster,,,,,,,1,,1
407062,,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,a,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1
407062,aaaa0,1,28/10/2015 10:32,28/10/2015 10:42,47326,Lemon Chicken Wings,,,,,,,1,,1';
my $regex = qr/[^,]*[,][^,]*[,][1][,]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}