using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(([\w-]+)=([\w.: -]+))(?= |$)";
string input = @" 0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf foo bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1
0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf_foo_bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}