import re
regex = re.compile(r"\b(([\w-]+)=([\w.: -]+))(?= |$)", flags=re.MULTILINE)
test_str = (" 0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf foo bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1\n\n"
" 0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf_foo_bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")