re = /\b(([\w-]+)=([\w.: -]+))(?= |$)/m
str = ' 0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf foo bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1
0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf_foo_bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end