use strict;
my $str = ' 0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf foo bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1
0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf_foo_bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1';
my $regex = qr/\b(([\w-]+)=([\w.: -]+))(?= |$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}