const regex = /\b(([\w-]+)=([\w.: -]+))(?= |$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(([\\w-]+)=([\\w.: -]+))(?= |$)', 'gm')
const str = ` 0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf foo bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1
0 interface=ether1 address=000.000.000.000 address4=000.000.000.000 mac-address=00:00:00:00:00:00 identity=adf_foo_bar platform=MikroTik version=6.29.1 unpack=none age=50s uptime=4h23m16s software-id=AAAA-BBBB board=RB750GL ipv6=no interface-name=bridge1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}