package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\s*`)
var str = `No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test asdfsdNo further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Testasdfasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}