re = /\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\s*/im
str = 'No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test asdfsdNo further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Testasdfasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end