const regex = /\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\s*/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test\\s*', 'img')
const str = `No further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Test asdfsdNo further distribution of this document is allowed without approval by the CEO or CFO MMR Policy Testasdfasd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}