#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^(?:\/[^\/\s]+)+Trash[^\/]*$"
Local $sString = "/a/b/.Trash" & @CRLF & _
"/a/b/.Trash+other words -> good" & @CRLF & _
"/a/b/.Trash -> good" & @CRLF & _
"/a/b/.blahTrash -> good" & @CRLF & _
"/a/.Trash -> good" & @CRLF & _
"/a/b/.Trash/c/d -> bad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")